import Foundation
let pattern = #"(?:(?<=,)|^)(?=("(?:[^"]+(?:"")*)*"|[^",]*))\1,"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""3,14","1,000,000",hippo,"cat,dog,frog",plain text,"2,25""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1;"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)