import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=,)|^)(?=(\"(?:[^\"]+(?:\"\")*)*\"|[^\",]*))\\1,";
final String string = "\"3,14\",\"1,000,000\",hippo,\"cat,dog,frog\",plain text,\"2,25\"";
final String subst = "\\1;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}