using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\b(?:Что|в)\b)(.{5})";
string input = @"Hi How Are you
Привет! Как дела, что делаешь? Не ходи в кино!
а наши люди в булочную на такси не ездят
Hi How Are you";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}