$re = '/(?=\b(?:Что|в)\b)(.{5})/mui';
$str = 'Hi How Are you
Привет! Как дела, что делаешь? Не ходи в кино!
а наши люди в булочную на такси не ездят
Hi How Are you';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);