#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^\d](;)\n"
Local $sString = "15;WB;250;2013-12-16;275;2013-12-16;18573; 16,00;" & @CRLF & _
"JAN KOWALSKI;WARSZAWA 1/9 m.5;" & @CRLF & _
"16;WB;3;2014-01-03;305;2014-01-03; 20,00;" & @CRLF & _
"JAN KOWALSKI;WARSZAWA;" & @CRLF & _
"17;WB;9;2014-01-10;382;2014-01-10; 30,00;" & @CRLF & _
"JAN KOWALSKI;WARSZAWA, Ulica JELEÑSKA 21 m.10;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")