import re
regex = re.compile(r"[^\d](;)\n")
test_str = ("15;WB;250;2013-12-16;275;2013-12-16;18573; 16,00;\n"
"JAN KOWALSKI;WARSZAWA 1/9 m.5;\n"
"16;WB;3;2014-01-03;305;2014-01-03; 20,00;\n"
"JAN KOWALSKI;WARSZAWA;\n"
"17;WB;9;2014-01-10;382;2014-01-10; 30,00;\n"
"JAN KOWALSKI;WARSZAWA, Ulica JELEÑSKA 21 m.10;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")