import Foundation
let pattern = #"[^\d](;)\n"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
15;WB;250;2013-12-16;275;2013-12-16;18573; 16,00;
JAN KOWALSKI;WARSZAWA 1/9 m.5;
16;WB;3;2014-01-03;305;2014-01-03; 20,00;
JAN KOWALSKI;WARSZAWA;
17;WB;9;2014-01-10;382;2014-01-10; 30,00;
JAN KOWALSKI;WARSZAWA, Ulica JELEÑSKA 21 m.10;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)