package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\d](;)\n`)
var str = `15;WB;250;2013-12-16;275;2013-12-16;18573; 16,00;
JAN KOWALSKI;WARSZAWA 1/9 m.5;
16;WB;3;2014-01-03;305;2014-01-03; 20,00;
JAN KOWALSKI;WARSZAWA;
17;WB;9;2014-01-10;382;2014-01-10; 30,00;
JAN KOWALSKI;WARSZAWA, Ulica JELEÑSKA 21 m.10;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}