use strict;
my $str = '15;WB;250;2013-12-16;275;2013-12-16;18573; 16,00;
JAN KOWALSKI;WARSZAWA 1/9 m.5;
16;WB;3;2014-01-03;305;2014-01-03; 20,00;
JAN KOWALSKI;WARSZAWA;
17;WB;9;2014-01-10;382;2014-01-10; 30,00;
JAN KOWALSKI;WARSZAWA, Ulica JELEÑSKA 21 m.10;';
my $regex = qr/[^\d](;)\n/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}