# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[,]+/,/g;t' <<< "EN:25,,,BR:18,,UE:21,,,NED:24,FR:20"