// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[,]+").unwrap();
let string = "EN:25,,,BR:18,,UE:21,,,NED:24,FR:20";
let substitution = ",";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}