$re = '/[,]+/';
$str = 'EN:25,,,BR:18,,UE:21,,,NED:24,FR:20';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;