using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[,]+";
string substitution = @",";
string input = @"EN:25,,,BR:18,,UE:21,,,NED:24,FR:20";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}