package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z0-9]+[A-Z0-9]+)|\[.*?\]|\".*?\"`)
var str = `Apply B23C to 23AB, ACDC1, 17X56QQE and DC45, then press [Remove] to open the screen "Installation".`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}