use strict;
my $str = 'Apply B23C to 23AB, ACDC1, 17X56QQE and DC45, then press [Remove] to open the screen "Installation".';
my $regex = qr/([A-Z0-9]+[A-Z0-9]+)|\[.*?\]|\".*?\"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}