$re = '/([A-Z0-9]+[A-Z0-9]+)|\[.*?\]|\".*?\"/m';
$str = 'Apply B23C to 23AB, ACDC1, 17X56QQE and DC45, then press [Remove] to open the screen "Installation".';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);