const regex = /([A-Z0-9]+[A-Z0-9]+)|\[.*?\]|\".*?\"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z0-9]+[A-Z0-9]+)|\\[.*?\\]|\\".*?\\"', 'gm')
const str = `Apply B23C to 23AB, ACDC1, 17X56QQE and DC45, then press [Remove] to open the screen "Installation".`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}