re = /([A-Z0-9]+[A-Z0-9]+)|\[.*?\]|\".*?\"/m
str = 'Apply B23C to 23AB, ACDC1, 17X56QQE and DC45, then press [Remove] to open the screen "Installation".'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end