# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?-.*?)(-.*)/\U$1\E$2/gm;t' <<< "Apple - Orange - Banana - Filename.txt
Grape - Orange - Banana - Filename.txt
"