use strict;
my $str = 'Apple - Orange - Banana - Filename.txt
Grape - Orange - Banana - Filename.txt
';
my $regex = qr/(.*?-.*?)(-.*)/mp;
my $subst = '\\U$1\\E$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";