$re = '/(.*?-.*?)(-.*)/m';
$str = 'Apple - Orange - Banana - Filename.txt
Grape - Orange - Banana - Filename.txt
';
$subst = "\U$1\E$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;