const regex = /(.*?-.*?)(-.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?-.*?)(-.*)', 'gm')
const str = `Apple - Orange - Banana - Filename.txt
Grape - Orange - Banana - Filename.txt
`;
const subst = `\U$1\E$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);