#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*?-.*?)(-.*)"
Local $sString = "Apple - Orange - Banana - Filename.txt" & @CRLF & _
"Grape - Orange - Banana - Filename.txt" & @CRLF & _
""
Local $sSubst = "\U$1\E$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)