package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*?-.*?)(-.*)`)
var str = `Apple - Orange - Banana - Filename.txt
Grape - Orange - Banana - Filename.txt
`
var substitution = "\U$1\E$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}