#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\$[^\(\);]+(?:\(\))?(?:\.[^\(\)]+(?:\(\))?)*?;"
Local $sString = "$get.q.htmlentities();" & @CRLF & _
"var val = $(this).val();" & @CRLF & _
"var val2 = $().val();" & @CRLF & _
"var val3 = "$placeholder;";" & @CRLF & _
"$get.q.htmlentities().func2();" & @CRLF & _
"$get.q.htmlentities().func2().wuuuut();" & @CRLF & _
"$get.q.htmlentities().func2(3);" & @CRLF & _
"$get.q.htmlentities(3).func2();"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")