// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\$[^\(\);]+(?:\(\))?(?:\.[^\(\)]+(?:\(\))?)*?;").unwrap();
let string = "$get.q.htmlentities();
var val = $(this).val();
var val2 = $().val();
var val3 = \"$placeholder;\";
$get.q.htmlentities().func2();
$get.q.htmlentities().func2().wuuuut();
$get.q.htmlentities().func2(3);
$get.q.htmlentities(3).func2();";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}