using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$[^\(\);]+(?:\(\))?(?:\.[^\(\)]+(?:\(\))?)*?;";
string input = @"$get.q.htmlentities();
var val = $(this).val();
var val2 = $().val();
var val3 = ""$placeholder;"";
$get.q.htmlentities().func2();
$get.q.htmlentities().func2().wuuuut();
$get.q.htmlentities().func2(3);
$get.q.htmlentities(3).func2();";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}