$re = '/\$[^\(\);]+(?:\(\))?(?:\.[^\(\)]+(?:\(\))?)*?;/';
$str = '$get.q.htmlentities();
var val = $(this).val();
var val2 = $().val();
var val3 = "$placeholder;";
$get.q.htmlentities().func2();
$get.q.htmlentities().func2().wuuuut();
$get.q.htmlentities().func2(3);
$get.q.htmlentities(3).func2();';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);