package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$[^\(\);]+(?:\(\))?(?:\.[^\(\)]+(?:\(\))?)*?;`)
var str = `$get.q.htmlentities();
var val = $(this).val();
var val2 = $().val();
var val3 = "$placeholder;";
$get.q.htmlentities().func2();
$get.q.htmlentities().func2().wuuuut();
$get.q.htmlentities().func2(3);
$get.q.htmlentities(3).func2();`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}