const regex = /<strong>.*111.*<\/strong>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<strong>.*111.*<\\\/strong>', 'g')
const str = `<div><strong>test</strong><div><strong>kkk</strong></div><div><strong>111</strong></div></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}