// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<strong>.*111.*<\/strong>").unwrap();
let string = "<div><strong>test</strong><div><strong>kkk</strong></div><div><strong>111</strong></div></div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}