re = /<strong>.*111.*<\/strong>/
str = '<div><strong>test</strong><div><strong>kkk</strong></div><div><strong>111</strong></div></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end