package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([а-яА-я]+\s[а-яА-я]+\s[а-яА-я]+)|([\w]+\s[\w]+\s[\w]+)|([\w]+\s[\w]+)`)
var str = `Иванов Иван иванович !@#$%^&*(_+1234567890-=[]?/
IVANOV Ivan ivanovich !@#$$^&*(_+1234567890-=~\`:"{};'[]|\<>?,./
IVANOV Ivan !@#$$^&*(_+1234567890-=~\`:"{};'[]|\<>?,./`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}