import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([а-яА-я]+\\s[а-яА-я]+\\s[а-яА-я]+)|([\\w]+\\s[\\w]+\\s[\\w]+)|([\\w]+\\s[\\w]+)";
final String string = "Иванов Иван иванович !@#$%^&*(_+1234567890-=[]?/\n"
+ "IVANOV Ivan ivanovich !@#$$^&*(_+1234567890-=~`:\"{};'[]|\\<>?,./\n"
+ "IVANOV Ivan !@#$$^&*(_+1234567890-=~`:\"{};'[]|\\<>?,./";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}