$re = '/([а-яА-я]+\s[а-яА-я]+\s[а-яА-я]+)|([\w]+\s[\w]+\s[\w]+)|([\w]+\s[\w]+)/i';
$str = 'Иванов Иван иванович !@#$%^&*(_+1234567890-=[]?/
IVANOV Ivan ivanovich !@#$$^&*(_+1234567890-=~`:"{};\'[]|\\<>?,./
IVANOV Ivan !@#$$^&*(_+1234567890-=~`:"{};\'[]|\\<>?,./';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;