import re
regex = re.compile(r"([а-яА-я]+\s[а-яА-я]+\s[а-яА-я]+)|([\w]+\s[\w]+\s[\w]+)|([\w]+\s[\w]+)", flags=re.IGNORECASE)
test_str = ("Иванов Иван иванович !@#$%^&*(_+1234567890-=[]?/\n"
"IVANOV Ivan ivanovich !@#$$^&*(_+1234567890-=~`:\"{};'[]|\\<>?,./\n"
"IVANOV Ivan !@#$$^&*(_+1234567890-=~`:\"{};'[]|\\<>?,./")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)