# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Cheese\\/([\-\%_0-9a-z]+)?(,)?[0-9]+/Cheese\/$1$25/ig;t' <<< "...by,Cheese/Night%20Out-Now,2...
...by,Cheese/2...
"