re = /Cheese\/([\-\%_0-9a-z]+)?(,)?[0-9]+/i
str = '...by,Cheese/Night%20Out-Now,2...
...by,Cheese/2...
'
subst = 'Cheese/$1$25'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result