const regex = /Cheese\/([\-\%_0-9a-z]+)?(,)?[0-9]+/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Cheese\\\/([\\-\\%_0-9a-z]+)?(,)?[0-9]+', 'ig')
const str = `...by,Cheese/Night%20Out-Now,2...
...by,Cheese/2...
`;
const subst = `Cheese/$1$25`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);