import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Cheese\\/([\\-\\%_0-9a-z]+)?(,)?[0-9]+";
final String string = "...by,Cheese/Night%20Out-Now,2...\n\n"
+ "...by,Cheese/2...\n";
final String subst = "Cheese/$1$25";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}