// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)Cheese\/([\-\%_0-9a-z]+)?(,)?[0-9]+").unwrap();
let string = "...by,Cheese/Night%20Out-Now,2...
...by,Cheese/2...
";
let substitution = "Cheese/$1$25";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}