# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Cheese\/([\-\%_0-9a-z]+)?(,)?[0-9]+"
test_str = ("...by,Cheese/Night%20Out-Now,2...\n\n"
"...by,Cheese/2...\n")
subst = "Cheese/$1$25"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.