# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/path.+?(?:foo=(\d+))(?![a-zA-Z\d])|path((?!foo).)*$//gm;t' <<< "path?foo=67
path?foo=67&bar=hello
path?bar=bye&foo=1&baz=12
path?bar=123
path
path?foo=37signals
path?foo=-8
something?foo=1
pathfoo
"