import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "path.+?(?:foo=(\\d+))(?![a-zA-Z\\d])|path((?!foo).)*$";
final String string = "path?foo=67 \n"
+ "path?foo=67&bar=hello \n"
+ "path?bar=bye&foo=1&baz=12\n"
+ "path?bar=123\n"
+ "path\n"
+ "path?foo=37signals\n"
+ "path?foo=-8\n"
+ "something?foo=1\n"
+ "pathfoo\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}