$re = '/path.+?(?:foo=(\d+))(?![a-zA-Z\d])|path((?!foo).)*$/m';
$str = 'path?foo=67
path?foo=67&bar=hello
path?bar=bye&foo=1&baz=12
path?bar=123
path
path?foo=37signals
path?foo=-8
something?foo=1
pathfoo
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;