using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"path.+?(?:foo=(\d+))(?![a-zA-Z\d])|path((?!foo).)*$";
string substitution = @"";
string input = @"path?foo=67
path?foo=67&bar=hello
path?bar=bye&foo=1&baz=12
path?bar=123
path
path?foo=37signals
path?foo=-8
something?foo=1
pathfoo
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}