const regex = /path.+?(?:foo=(\d+))(?![a-zA-Z\d])|path((?!foo).)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('path.+?(?:foo=(\\d+))(?![a-zA-Z\\d])|path((?!foo).)*$', 'gm')
const str = `path?foo=67
path?foo=67&bar=hello
path?bar=bye&foo=1&baz=12
path?bar=123
path
path?foo=37signals
path?foo=-8
something?foo=1
pathfoo
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);