import Foundation
let pattern = #"path.+?(?:foo=(\d+))(?![a-zA-Z\d])|path((?!foo).)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
path?foo=67
path?foo=67&bar=hello
path?bar=bye&foo=1&baz=12
path?bar=123
path
path?foo=37signals
path?foo=-8
something?foo=1
pathfoo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)