#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".* behavior: (?<NumActive>\d+) active, (?<NumLoading>\d+) loading, \d+ loaded, (?<NumFailed>\d+) failed, \d+ idle, (?<NumTotal>\d+) total"
Local $sString = "Vyopta.vMonitor.MonitorManager: Summary: behavior: 603 active, 0 loading, 0 loaded, 180 failed, 0 idle, 783 total"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")