re = /.* behavior: (?<NumActive>\d+) active, (?<NumLoading>\d+) loading, \d+ loaded, (?<NumFailed>\d+) failed, \d+ idle, (?<NumTotal>\d+) total/
str = 'Vyopta.vMonitor.MonitorManager: Summary: behavior: 603 active, 0 loading, 0 loaded, 180 failed, 0 idle, 783 total'
# Print the match result
str.match(re) do |match|
puts match.to_s
end